Como compilar os projetos dos livros de Android

Posted by rlecheta on setembro 25, 2015
Android, Livro Android

Olá pessoal, segue dicas de como compilar os projetos baixados dos meus livros de Android, ou de qualquer outro 🙂

Depois de entrar na área de download do livro, baixe os projetos.

http://livroandroid.com.br/site/pages/downloads.php

Você verá uma pasta com vários capítulos assim:

Screen Shot 09-25-15 at 01.38 PM

Então digamos que você queira abrir o projeto de exemplo do capítulo 7.

No Android Studio, selecione o wizard > File > Open > e selecione o local do projeto.

É aqui que está o problema, e as vezes o pessoal se atrapalha para compilar o projeto.

Dependendo de suas configurações, como a versão do Android SDK e Build-Tools que você fez o download, é necessário fazer alguns ajustes no projeto.

img_150925_0144

Na janela Messages podemos ver o seguinte erro:

Error:Gradle 2.4 requires Android Gradle plugin 1.2.0 (or newer) but project is using version 1.0.1.
Please use Android Gradle plugin 1.2.0 or newer.

img_150925_0145

Para solucionar este problema abra o arquivo build.gradle que fica na raiz do Android Studio e atualize a seguinte linha para a última versão:

Qual versão deve ser? Bom, provavelmente o Android Studio vai mostrar o assistente de código e vai te ajudar. Só clique no assistente que ele deve corrigir.

classpath 'com.android.tools.build:gradle:1.3.0'

a

Outro problema frequente pode ser a versão do SDK Build-tools, que é a ferramenta utilizada para compilação do projeto. Podemos ver na figura abaixo que meu build-tools está com a versão 23.0.1.

@Obs: sempre deixe atualizado estes pacotes;

a

Isso significa que no arquivo app/build.gradle preciso colocar a versão 23.0.1 no campo buildToolsVersion. Somente assim o projeto compilará.

b

Outro ajuste que muitas vezes é necessário é configurar a API Level target do projeto.

Isso é feito nos atributos compileSdkVersion e targetSdkVersion.

Conforme mostra o print abaixo, esses atributos estão configurados com a API Level 21 (Android 5.0). Você verá que o Android Studio sinaliza em um tom de amarelo que existe uma nova versão do Android.

img_150925_0153

Como depois do livro Android 4ª edição foi lançado o Android 6.0 (API Level 23), podemos ajustar no arquivo app/build.gradle a API Level target para compilação.

Depois dos ajustes para API = 23, o resultado fica assim:

b

Outra coisa que pode acontecer, é ter sido lançada bibliotecas mais atualizadas do Android.

Isso acontece muito com as bibliotecas de compatibilidade e Google Play Services. Portanto, quando estiver lendo o livro você pode atualizá-las, caso queira.

Lá na parte das dependências, geralmente essas bibliotecas de compatibilidade seguem a nomenclatura do build-tools. Então se o build-tools está na versão 23.0.1, estas libs devem estar com a mesma versão.

Veja na figura:

c

Mas para ter certeza qual a versão da lib de compatibilidade, basta ver no SDK Manager qual versão você fez o download, lá na pasta Extras. Podemos ver que baixei a versão 23.0.1 ,e por isso no arquivo app/build.gradle a configuração é feita com a mesma numeração.

d

Não é o caso deste projeto que escolhi, mas as vezes podem ter mais libs, como a do Google Play Services.

Por exemplo, no cap 23 do livro tem o projeto de exemplo com Mapas e GPS, que usa o Google Play Services.

Ao abrir o projeto, o arquivo app/build.gradle  está assim:

Podemos ver que o Android Studio sugere que a versão da lib seja atualizada. Então basta clicar no assistente do editor, ou utilizar a tecla de atalho Ctrl+Enter para efetivar a alteração.

e

Espero que estas dicas ajudem o pessoal que está começando com Android a compilar os projetos já existentes.

Esses problemas são comuns, pois ao desenvolver o projeto você faz a compilação com a versão das libs que existem na época. Porém como as atualizações são constantes, temos estes problemas.

São coisinhas chatas do Android, mas simples de resolver e que logo agente se acostuma 🙂

Qualquer dúvida é só entrar em contato!

9 Comments to Como compilar os projetos dos livros de Android

  • Boa noite,
    estou tentanto importar o projeto do cap04 e quando vou alterar o arquivo build.gradle, ele retorna a seguinte mensagem:

    Migrate Project to Gradle?
    This project does not use the Gradle build system. We recommend that you migrate to using the Gradle build system.
    More Information about migrating to Gradle
    Don’t show this message again.

    Estava olhando algumas soluções que você descreveu acima mas não encontrei nada parecido.
    pfv você pode me ajudar?

    • Oi Alex, agora que vi a mensagem. Conseguiu resolver? Talvez você abriu a pasta errada, testei aqui e está ok o projeto.

    • Oi William, o link está errado, como vc fez pra achar ele? Entra no site em livroandroid.com.br e clica em downloads que vai pro link certo.

  • Bom Dia, apliquei todas esses configuracoes para rodar o projeto do capitulo22 do livro 5ed, mas quando rodei deu problema de compatibilidade: minSdk(API 19) > minSdk(API 1).

    Alguém pode me ajudar?

    • Oi Charles, veja o minsdk que está no build.gradle. Seu emulador precisa ter a versao igual ou maior a esta. Para outras dúvidas utilize o forum de ajuda para os livros.. eu postei aqui no blog o link, abs

  • Olá!

    Estou Na página 406 do livro 5ª edição ao inserir dependência:
    compile ‘br.com.livroandroid:android-utils:1.0.5 da erro
    failed to resolve:br.com.livroandroid:android-utils:1.0.5

    sendo que essa versão está mais atual do que a do livro,compile ‘com.android.support:appcompat-v7:24.2.0’